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Introduction to What's New 

This edition of the "What's New" describes many notable new features and enhancements in 

version 10.97 since the previous release (10.96.2). For information on features and 

enhancements made in earlier versions, see the appropriate "What's New" document for 

those versions. 

 

For information on fixes made in version 10.97, see the appropriate "Resolved Issues" 

document.  

 

Note that if updates need to be made, the most up to date "What's New" and "Resolved 

Issues" documents can be found in our online documentation here:  

 

Release Notes 

 

This document was last updated on March 15th, 2020. 

Structure of the Document 

This document is split into chapters for the different areas of the ICONICS Suite, then 

further into sections for major updates, representing significant enhancements or new 

functionality, followed by tables of additional enhancements and fixes. 

Where appropriate, references to additional information, such as instructional 

application notes or help files, will be indicated. 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Com/Intro/Release_Notes.htm
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Most Notable Features 

Some of the most notable new features in 10.97 are listed below. Visit each link to learn 

more and see the "Major Enhancements" sections for each product for additional 

notable features. 

• New Hyper Alarm Server 

• ICONICS Suite installation is now secure by default 

• CFSWorX now includes: 

o Integration with Maximo, ServiceNow, and Azure Active Directory 

o Support for load balancing 

• Hyper Historian Data Exporter now supports Amazon Simple Storage Service 

(Amazon S3) and Azure Data Lake Generation 2 

• Sankey Diagram control for GraphWorX64, MobileHMI, and KPIWorX 

• Project Reporting now uses ReportWorX64 technology and no longer requires 

SQL Server Reporting Services 
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Common & Platform Services 

General 

Major Enhancements 

Additional Data Sources for Query Interface 

In version 10.97 a number of other data providers were enhanced to provide data via 

the query interface, making it easier and more efficient to display this data in the table 

control and opening the door for future compatibility. These providers include: 

• AnalytiX-BI Server 

• AssetWorX Point Manager 

• Web Services Point Manager 

The query interface is an ICONICS protocol for retrieving datasets. It has been designed 

to be more efficient at retrieving data, especially when the original dataset needs to be 

modified, such as by sorting, calculating aggregates, or displaying only a subset of the 

columns. The query interface allows the server to process those modifications more 

efficiently before sending the data to the client, whereas with the original dataset 

protocol the client had to retrieve the entire dataset and modify it on the fly in runtime. 

Currently only a few controls can use the query interface to read data from these 

providers. These controls include the Table control, Fault Viewer, and Sankey Diagram. 

Future enhancements will broaden this support to other areas of ICONICS Suite. 

For Further Reference 

• Help: Data Sources for Query Interface 

Azure SQL Server Connections Now Support Azure Active Directory Integrated Security 

(Reference ID: 77609) 

Previously, configuration databases stored in Azure SQL Server could only be used with 

SQL authentication or with Azure Active Directory credentials specified in the connection 

string. Now, configuration databases can support Azure Active Directory Integrated 

Security when the ICONICS services are running under an Azure Active Directory 

account. 

This support includes logging databases for AlarmWorX64 Logger and the legacy 

TrendWorX64 Logger. (Note, ICONICS still highly recommends Hyper Historian Express 

over the TrendWorX64 Logger for new projects.) 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Com/Intro/Data_Sources_for_Query_Interface.htm
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The Fault Viewer currently does not support Azure Active Directory. We plan to add 

Azure Active Directory support for this in a future version. 

AlarmWorX64 Multimedia and Workbench Classic do not support Azure SQL Server or 

Azure Active Directory authentication. 

Additional Enhancements 

Commanding 

Ref ID Description 

80772 The Axis Stroke property can now be set in the Create Pen command. 

Data Browser 

Ref ID Description 

49625 
The data browser now contains a "Stop" button. This button can stop (cancel) a browsing operation if it is taking too 

long. 

Expressions 

Ref ID Description 

72069 The expression editor no longer automatically selects whole words when changing the selection. 

74171 Enhanced the descriptive tooltips for the toepoch and fromepoch functions. 

FrameWorX Server 

Ref ID Description 

80220 For security reasons, the FwxServer.Network.config file has been moved into C:\ProgramData\ICONICS. 

80325 The REST API transport option is no longer available in the FrameWorX Server Location dialog. 

80326 Web Sockets is now the default transport protocol for FrameWorX in new installations. 

80371 

Previously, point managers could only be enabled or disabled after a restart of FrameWorX (for in-process point 

managers) or the specific point manager (for out-of-process point managers). Now, they can be enabled or disabled 

immediately upon applying the changes. This behavior is optional and is controlled with a checkbox on the bottom 

of the Point Managers tab in Platform Services Configuration. 

GenEvents 

Ref ID Description 

69195 

The GenEvent messages for successful or failed writes can be replaced with custom messages. To specify a custom 

message or comment, edit FwxServer.Network.config (located by default in C:\ProgramData\ICONICS). Edit the items 

in the AuditLogMessagesOverride section. An empty value indicates the default message will be used. These 

messages are not localizable. FrameWorX must be restarted for the changes to take effect. 

 

Each string may contain the following parameters, which must be enclosed in curly brackets {}. They are not case-

sensitive. 

 Result 

 PointName 

 PrevValue 

 NewValue 

 Source 
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Ref ID Description 

 MachineName 

 ProcessName 

 IPAddress 

 UserName 

  

Examples: 

    <WriteSucceededMessageFormat>Result={result}; PointName={pointName}; Prev={prevValue}; New={newValue}; 

Source={source};</WriteSucceededMessageFormat> 

    <WriteSucceededCommentFormat>MachineName={machineName}; Process={processName}; IP={IPAddress}; 

User={userName};</WriteSucceededCommentFormat> 

Global Search 

Ref ID Description 

81009 
In Global Search Settings, the EtherNet/IP and Mitsubishi Electric providers are now configured to index by default. 

Their global search settings have been made consistent with the settings for other similar providers. 

81012 The global search can now automatically recover if the search index database has become corrupted or damaged. 

Health Monitoring 

Ref ID Description 

74581 
Health Monitor rules can now optionally specify an Event ID when logging system events. Previously all rules used an 

Event ID of 0. 

82160 

The ICONICS Health Monitor Services is now configured with a startup type of manual by default. This is to prevent 

the unintentional use of system resources by users who do not use Health Monitoring tags or pages. Users who do 

wish to use these features can start the service manual or change its startup type to automatic or automatic 

(delayed). 

Installation 

Major Enhancements 

Secure by Default Installation 

(Reference ID: 76614) 

In previous versions, installing ICONICS Suite onto a new system without any previous 

configuration resulted in a system that was completely open as far as security was 

concerned. This was convenient from a demonstration or testing perspective but caused 

concern for security-minded users who may have wanted to minimize risk while setting 

up a production system. 

Version 10.97 enhanced the installation procedure to create a more secure ICONICS 

installation from the start, while still offering users the option to create a conveniently 

open system for demonstration or testing, if needed.  

During installation, the user is now prompted for an ICONICS security username and 

password. By default, ICONICS Suite is installed with security enabled, and a user is 

created using the name and password supplied during installation.  
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If desired, the user can choose to install a demonstration system. In this case, ICONICS 

Suite is installed with security in "testing" mode. A username and password are still 

required by the installation, and a user will be created in the initial security 

configuration, but no login will be required to use or configure the system. 

Unless a demonstration system is chosen, a minimal set of applications are enabled after 

installation – only those necessary to run Workbench. Having as few applications and 

services running as possible provides a more secure and efficient system. As a first step 

after installation, the user should follow the steps below to use Workbench to enable 

the specific applications they need for their system. 

The IcoGenApps application pool in IIS is now disabled by default unless a 

demonstration installation is chosen. Disabling this application pool creates a more 

secure system but prevents WPF WebHMI (usable in Internet Explorer only) clients 

connecting. HTML5 WebHMI and MobileHMI clients can still connect with this 

application pool disabled. Users who require WPF WebHMI can use Workbench to 

enable this application pool.  

To activate additional applications or the GENESIS64 IIS application pool: 

1) Open Workbench. 

2) Log into ICONICS security. 

3) Open the Configure Application(s) settings page with one of the following 

methods: 

a. In Project Explorer, open the context menu for the project and select 

Configure Application(s) settings. 

OR 

b. Go to Home and select Configure Application(s) settings. 

4) In the Available Applications section, find the applications you would like to 

enable and do the following for each: 

a. Enable the checkbox. 

b. Choose a SQL Server and catalog. 

c. In the first column, select the  Create or overwrite the database 

associated with this application button. 

d. A warning dialog will appear. Select Ok. 

5) If desired, select the Enable GENESIS64 IIS Application Pool. 

6) Select Apply. 

7) A warning dialog may appear. Select Ok. 

8) If prompted, restart the ICONICS FrameWorX service. 

To activate and configure AlarmWorX64 Multimedia on a secure system: 
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1) Open the Windows Services control panel. 

2) Change the startup type of the ICONICS AlarmWorX64 Multimedia service 

from Disabled to either Manual, Automatic, or Automatic (Delayed), 

depending on your desired behavior. 

3) The Services window can be closed. 

4) Open AlarmWorX64 Multimedia or Layout and Multimedia Manager. 

5) Go to Project > Edit Project. 

6) Select Add > AlarmWorX64 Multimedia. 

7) Select Close. 

8) From the bottom of the Project Explorer, select AlarmWorX64 Multimedia. 

9) Right-click on localhost and select New Database. 

10) Follow the wizard to create an AlarmWorX64 Multimedia configuration database. 

11) When the wizard is complete, right-click on the new database in Project 

Explorer and select Make Active. 

12) Configure AlarmWorX64 Multimedia as needed. 

13) When prompted, save your project file. 

For Further Reference 

• Help: Secure by Default Installation 

Additional Enhancements 

Ref ID Description 

52547 

When performing a custom installation and selecting only the "Client" features, the installation will ask for the 

FrameWorX connection for the primary server. This functionality was originally part of the separate "ICONICS Client" 

installation. This makes installing a thick client more convenient, as users no longer need to run the FrameWorX 

Server Location utility after installation. 

78998 

The process of upgrading an existing installation has been improved. The database creation wizard now has greater 

clarity and does a better job guiding a user who is upgrading. Also, the wizard no longer forces the creation of 

configuration tables that were not part of the original configuration. 

Language Aliasing 

Language Aliasing Workbench Provider 

Ref ID Description 

60137 The description for language alias groups is now visible and editable in Workbench. 

Licensing 

Ref ID Description 

54811 
Enhanced the tracing when connecting to the cloud license server when an error occurs that could be due to an 

incorrect password or license pool ID. 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Com/Intro/Secure_by_Default_Installation.htm
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MonitorWorX Viewer 

Ref ID Description 

80675 

If the standalone MonitorWorX Viewer is minimized to the task tray and the user attempts to launch it again from the 

start menu, the already running MonitorWorX Viewer window will be restored. Previously, attempting to launch the 

MonitorWorX Viewer again would result in no change, possibly leading users to conclude it was hung or broken if 

they did not realize it was running in the task tray. 

Project Reporting 

Ref ID Description 

52901 Project Reporting now supports Workbench projects that include multiple servers. 

79115 Added an "Automatically fit report content" option to the Project Reporting forms. 

Security 

Security Workbench Provider 

Ref ID Description 

44515 
Users and groups now contain three new buttons at the bottom for "Administrator", "Operator", and "Read Only". 

These buttons can be used to quickly grant a user or group a standard set of permissions for the given level.  

73286 
The "Test current Allow/Deny configuration" field on the Files tab for users or groups now includes a file browser 

instead of a tag browser. 

Tools 

ConverterWorX 

Ref ID Description 

35372 
The ConverterWorX Importer now allows browsing for the SQL Server instance in the appropriate fields. Previously 

this value had to be entered manually. 

50412 
Enhanced the TrendWorX32 Logger to Hyper Historian conversion process to ensure a more accurate conversion of 

tags with expressions as the tag source. 

53545 

When converting GraphWorX32 displays to GraphWorX64, Popup Window pick actions are now converted to Load 

Display actions with a target type of Popup Window (Display Dependent). Previously they were converted to target 

type, Popup Window (Window Dependent). Display Dependent is more consistent with the behavior in 

GraphWorX32. 

72705 

72147 

Enhanced the AlarmWorX32 Logger to AlarmWorX64 Logger conversion process to ensure a more accurate 

conversion. 

77659 Enhanced the DBOPC Server to GridWorX Server conversion process to ensure a more accurate conversion. 

TraceWorX 

Ref ID Description 

72816 

Enhanced the speed of TraceWorX logging. Exact performance will vary per application, but controlled tests showed a 

60-80% speed improvement.  

 

Users are still encouraged to only enable TraceWorX logging when troubleshooting an issue. Tracing may still have a 

noticeable effect on performance of the module being traced. 
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Triggers 

Triggers Workbench Provider 

Ref ID Description 

79126 
Users can now use the expression editor when configuring points for data triggers. Select the tag browser button and 

go to the Expressions tab. (Expressions were supported previously, but they had to be entered manually.)  

Web Platform Services (WebAPI) 

Major Enhancements 

General 

Support for Docker, Kubernetes, and Redis 

(Reference ID: 77678) 

Web Platform Services now supports running in Docker containers. It also supports 

scaling using Kubernetes and sharing Machine Keys using Redis. 

For more information about deploying the Web Platform Services Docker container, see 

the Extensibility ToolWorX documentation. (Contact your sales representative or 

distributor for information on obtaining Extensibility ToolWorX.) 

REST OData Provider 

Support for Standard and Historical Datasets 

(Reference IDs: 71305, 78049) 

REST API calls can now be used to return standard datasets and historical datasets.  

The following is an example standard dataset API call that returns data from the 

Northwind Orders table where the ShipCountry is "Germany": 

https://hostname/fwxapi/odata/v1/ODataDataset?pointName=db:Northwind.Orders&$fi

lter=(ShipCountry eq 

'Germany')&$count=true&$top=3&$format=application/json;odata.metadata=none 

The following is an example historical dataset API call for the Signals > SineFast point. 

https://hostname/fwxapi/odata/v1/ODataHistory?pointName=hh:\Configuration\Signals:

SineFast&StartDate=2020-07-21T11:25:00-0400&EndDate=2020-07-21T11:27:00-

0400&$count=true&$filter=(statusCode eq 0)&$top=8 
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For Further Reference 

• Application Note: GENESIS64 - Setting up WebAPI REST 

• Help: Support for Standard and Historical Datasets 

Support for Swagger 

(Reference ID: 71298) 

Web Platform Services now supports Swagger. Swagger allows for autogenerated 

documentation of the REST API and the ability to test API endpoints in the browser. It 

also makes it easier to connect with third-party services, such as Microsoft Power Apps. 

The Swagger documentation is accessible at 

https://hostname/fwxapi/swagger/index.html.  

For Further Reference 

• Application Note: GENESIS64 - Setting up WebAPI REST 

• Help: Support for Swagger 

Additional Enhancements 

Ref ID Description 

72936 
WebAPI API calls now support real-time data updates when using WebSockets. See the help documentation for more 

information on how to configure real-time data updates. 

74205 

A REST API has been added for the global search. Below are some examples: 

 

To search the whole address space for "mySearchText": 

http://<hostname>/fwxapi/rest/Data/Search?text=mySearchText. 

 

To search using a starting point of ac:Company (point name): 

http://<hostname>/fwxapi/rest/Data/Search?text=mySearchText&startPointName=ac%3ACompany  

 

To search using a starting point of My Computer/Assets/Company (display path): 

http://<hostname>/fwxapi/rest/Data/Search?text=mySearchText&startPath=My+Computer%2FAssets%2FCompany 

 

This REST API requires authentication. See the application note entitled, "GENESIS64 - Setting up WebAPI REST" or 

the help documentation for more information. 

77522 

Web Platform Services plug-ins can now use cookie authentication.  

 

In addition, URL rewrite support has been enhanced. It is now possible to specify allowed headers, the number of 

reverse proxies in the path, which proxy IP addresses are allowed, and more. This is configurable in 

\ICONICS\GENESIS64\WebSites\IcoWebAPIService\appsettings.json. 

 

See Extensibility ToolWorX documentation for more information on these features. (Contact your local sales 

representative or distributor for information on obtaining Extensibility ToolWorX.) 

78769 

All API endpoints now support versioning (such as "/v1/" in the URL). This will aid in maintaining backwards 

compatibility while allowing more flexibility in implementing future improvements. URLs that do not specify a version 

will use the v1 API. 

78782 

Plug-ins for the Web Platform Services can now support localization using simple JSON files. See Extensibility 

ToolWorX for information on how to create a Web Platform Services plugin that leverages the localization capability.  

 

Web Platform Services REST API calls can now specify the culture used to translate language aliases that might be 

returned in the call. Previously all calls used the server's default culture for translating language aliases. Culture can 

be specified using a parameter, header, or cookie consistent with ASP.NET Core standard localization standards. 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/WebAPI/Support_for_Standard_and_Historical_Datasets.htm
https://hostname/fwxapi/swagger/index.html
https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/WebAPI/Support_for_Swagger.htm
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Ref ID Description 

 

An example REST API call that specifies the culture would be: 

https://hostname/fwxapi/rest/v1/data?pointName=ac:MainBuilding/localizedProperty&culture=cs-CZ 

 

More documentation on specifying the culture can be found in Extensibility ToolWorX. (Contact your local sales 

representative or distributor for information on obtaining Extensibility ToolWorX.) 
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AnalytiX 

AnalytiX-BI 

Major Enhancements 

Support for Query Interface and Table Control 

(Reference ID: 74982) 

AnalytiX-BI can now provide data via the query interface. This means that controls that 

support the query interface (such as the table control, when using a type of "query") can 

connect to AnalytiX-BI and display data from a data model. 

To see data from an AnalytiX-BI data model in the table control: 

1) Configure the table control. 

2) For Query, select type. 

3) For Data Source, browse under AnalytiX > BI Server > Data Models and select 

your desired data model.  

4) For Table, select the desired table from the data model. 

5) Go to the Fields page. 

6) Select the refresh  button. 

7) Go to the Columns page. 

8) Select the refresh  button. 

9) Make further updates to Fields or Columns as desired. 

10) Select OK. 

11) Go into runtime to see your data. 

Future ICONICS products that use the query interface will be able to access AnalytiX-BI 

information in a similar fashion. 

Query interface support was added for additional data sources. See Additional Data 

Sources for Query Interface for more information. 

For Further Reference 

• Help: Support for Query Interface and Table Control 

Additional Enhancements 

AnalytiX-BI Server 

Ref ID Description 

65346 AnalytiX-BI queries now support LEFT and OUTER joins. 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/AnalytiX_BI_Server/Support_for_Query_Interface_and_Table_Control.htm
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Ref ID Description 

66951 
The Real-time and Asset Property Values steps in data flows now include a "Batch read delay" property that specifies 

the amount of time to wait before each batch request. 

76055 

Previously, if the user is scrolled down in a data flow preview, adding a new step would refresh the preview and jump 

the user back to the top. Now, the scroll position is saved and restored after the refresh, so the user does not lose his 

place in the preview. 

80393 

Data flows can now read AssetWorX time zones. Dimensions > Assets, Asset Properties and Energy all return a new 

column called "TimeZoneId" which reflects the time zone for the asset or property as it is configured in AssetWorX. If 

the time zone is set "As Specified" the value for the asset / property will be returned; otherwise, the closest parent 

with its time zone set to "As Specified" will be returned. If no assets in the hierarchy for the selected asset / property 

has its time zone set, null or empty string will be returned as time zone id. 

AnalytiX-BI Workbench Provider 

Ref ID Description 

80394 

80823 

Data flows can now use the totimezoneinfo function (available for steps and parameters). This function takes two 

parameters, a datetime to convert, and a time zone ID. The datetime converted into the specified time zone. This can 

be used to align the times of two different datasets. 

 

The totimezoneinfo function can also take a third optional parameter that identifies the source time zone of the 

datetime value. If this parameter is not specified, the time zone is assumed to be local. 

BridgeWorX64 & Workflow 

Common 

Ref ID Description 

71459 

The delay activity now exposes an output dataset. This dataset exposes a single Boolean value in a column named 

"CompletedByTimeout". This value can be used by subsequent activities to tell if the delay ended due to the timeout 

or due to the expression. 

75897 
Activities that have a single data source now support expressions in the Point Name field. This includes the Data Set 

Reader, Historical Alarms Input, Data Manipulator, Bulk Data Manipulator, and Web Service Manipulator. 

77723 

Previously, Workflows, BridgeWorX64 transactions, and CFSWorX workflows could only hibernate on a delay block 

with a fixed wait period. Now the delay block can hibernate on variable delays. A workflow or transaction that is 

hibernating will periodically "awaken" to check the wait expression. 

BridgeWorX64 Server 

Ref ID Description 

66954 

BridgeWorX64 configurations now have an "Automatic" option for the "Number of Threads" setting in the Advanced 

Properties section. Enabling "Automatic" will allow the BridgeWorX64 engine to dynamically check the CPU cores and 

set an appropriate thread pool. 

75199 

72707 

"Send Push Notifications" activity added for BridgeWorX64 and CFSWorX workflows. This sends Azure-based push 

notifications that were introduced in 10.96 for the Universal Windows Platform (UWP) app and in 10.96.1 for iOS and 

Android apps. 

BridgeWorX64 & Workflow Workbench Providers 

Ref ID Description 

67000 
Users can now upload an example JSON into the JSON Content Reader activity to automatically load the schema. Use 

the Load Schema link in JSON Reader Settings under JSON Parse Mode. 
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CFSWorX 

Major Enhancements 

General 

Additional CRM and CMMS Integrations (Maximo, ServiceNow, Azure Active Directory) 

(Reference ID: 77225, 77227, 77426) 

Version 10.97 adds CFSWorX integration with the following CRM and CMMS systems. 

Integration Worker 

Contact Info 

Groups & 

Skills 

Schedules Work 

Orders 

Maximo ✓ ✓ 
 ✓ 

ServiceNow ✓ ✓ ✓ ✓ 

Azure Active 

Directory 

✓ ✓ ✓ n/a 

 

Note, Azure Active Directory does not manage work orders. Maximo does not currently 

make their schedules available via their APIs. ICONICS plans to add Maximo schedule 

integration when possible. 

For Further Reference 

• Help: 

o Configuring Maximo 

o Configuring ServiceNow 

o Adding an Azure Active Directory Source 

Worker Access 

Obtain Worker Location from Dynamics 365 

(Reference IDs: 66124, 80598) 

Instead of using MobileHMI device health data, the location of workers can now be 

determined from Dynamics 365. On the desired field worker source object, select the 

Use CRM Location box to get location from Dynamics 365. (See help files for 

information on how to enable the field technician location tracking feature in Dynamics 

365 for Field Service.) 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/Connected_Field_Worker/Configuring_Maximo.htm
https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/Connected_Field_Worker/Configuring_ServiceNow.htm
https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/Connected_Field_Worker/Field_Workers.htm#Adding_an_Azure_Active_Directory_Source
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For Further Reference 

• Help: Obtain Worker Location from Dynamics 365 

Workflows and Alerts 

Workflow Load Balancing and Redundancy 

(Reference ID: 76066) 

The load balancing and redundancy features introduced for BridgeWorX64 in version 

10.96.0 are now available in CFSWorX for workflows. CFSWorX schedulers keep track of 

the queue of workflows that need to be executed and dispatch them to running 

CFSWorX workflow engines. If one engine fails, the schedule will dispatch transactions to 

the remaining engines. Redundant schedulers can be configured, but only one will run 

active at a time. 

The configuration of load balancing is the same as for BridgeWorX64. CFSWorX 

workflows can have the same recovery modes as BridgeWorX64 transactions. 

Note that interrupted workflows can either be restarted from the beginning or not 

recovered at all. CFSWorX is not able to resume the workflow where it left off. 

For Further Reference 

• Help: Workflow Load Balancing and Redundancy 

Additional Enhancements 

Ref ID Description 

68861 

Field workers can be enabled or disabled based on the value of a Boolean tag. Select the user in Workbench under 

Connected Field Workers > Field Workers > source, check the box for "Enable on Tag", then fill in the desired tag 

value. Note, if the tag cannot be evaluated or if it is not a Boolean value, the worker will be disabled. 

71723 

In previous versions, users could retrieve the count of field workers that match a query by creating a query tag that 

specified an index of -1. This functionality is unchanged, but users can now browse for the @@Count tag under 

Connected Field Worker > Field Workers > worker source to get a tag with the index pre-filled with -1, eliminating 

the need to remember the correct syntax. 

74296 Enhanced the TraceWorX tracing to better report when the product is disabled due to licensing. 

74965 

Added support for using Azure maps to calculate worker distance and travel time. See help documentation for 

AnalytiX Suite > CFSWorX > Templates > Sort Workers Based on Travel Time for instructions on how to configure 

Azure maps. 

74977 
Field worker images are now re-imported whenever the point manger is started or when performing a manual "Sync 

Now" from Workbench. Previously the worker images were only ever imported when the worker was first imported. 

79809 

Added these additional performance counters to the Connected Field Worker point manager: 

 

Active Geofence Alarms 

Azure AD API Calls 

Azure AD API Errors 

Cache read rate 

Database read rate 

Dynamics 365 API Calls 

Dynamics 365 API Errors 

Number of groups configured 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/Connected_Field_Worker/Configuring_Dynamics_365.htm#Obtain_Worker_Location_from_Dynamics_365_
https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/Connected_Field_Worker/Workflow_Load_Balancing_and_Redundancy.htm
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Ref ID Description 

Internal Schedule Errors 

Maximo API Calls 

Maximo API Errors 

Mobile Updates 

SalesForce API Calls 

SalesForce API Errors 

ServiceNow API Calls 

ServiceNow API Errors 

Number of workers configured 

80726 
Recipients can now respond to a Vonage WhatsApp alert message from CFSWorX to acknowledge the alarm or fault. 

This works consistent with other acknowledgment support, such as with Twilio WhatsApp or SMS. 

80884 CFSWorX sources now support online changes via PowerShell. 

80899 
Added support for Vonage public sandbox API for WhatsApp, allowing users to test AlertWorX or CFSWorX alerts 

with Vonage before purchasing a Vonage plan. 

CFSWorX Workflows 

Ref ID Description 

70658 The NT Event Output block is now allowed in CFSWorX workflows. 

75199 

"Send Push Notifications" activity added for BridgeWorX64 and CFSWorX workflows. This sends Azure-based push 

notifications that were introduced in 10.96 for the Universal Windows Platform (UWP) app and in 10.96.1 for iOS and 

Android apps. 

77689 
Added a new Alarm Delay activity. This activity can periodically check for new alarm values and end the delay based 

on those values. (The standard Delay block will not reevaluate alarm values.) 

77723 

81674 

Previously, Workflows, BridgeWorX64 transactions, and CFSWorX workflows could only hibernate on a delay block 

with a fixed wait period. Now the delay block can hibernate on variable delays. A workflow or transaction that is 

hibernating will periodically "awaken" to check the wait expression. 

Energy AnalytiX 

Major Enhancements 

Dashboards 

Dashboards and Data Model Updates Utilizing Sankey Diagram 

(Reference ID: 77438) 

The Energy AnalytiX data model and sample dashboards have been updated to utilize 

the new Sankey Diagram widget. 

The data model has three new views, EnergyConsTotalsAreaView, 

EnergyConsTotalsEnterpriseView, and EnergyConsTotalsSiteView. These views are 

used in three new dashboards available in the new Consumption Flows folder. The new 

dashboards are named Area Level Flows, Site Level Flows, and Enterprise Level 

Flows. They visualize the flow of energy of various levels. 

For Further Reference 

• Application Note: Energy AnalytiX – Sample Energy Dashboards 

• Help: Dashboards and Data Model Utilizing Sankey Diagrams 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/EA/Dashboards_and_Data_Model_Utilizing_Sankey_Diagrams.htm
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Additional Enhancements 

Ref ID Description 

79169 

It is now easier to display data from assets in different time zones. The Energy AnalytiX AnalytiX-BI data models and 

KPIWorX dashboards can now take advantage of the time zones defined in AssetWorX to ensure that daily data is 

retrieved using the correct start and end times for the day local to the asset. For example, when displaying a day's 

worth of data from both Boston and London assets, the Boston data will be retrieved from 12 midnight to 12 

midnight Boston time and the London data will be retrieved from 12 midnight to 12 midnight London time, even 

though 12 midnight is a different UTC time for each asset. When displayed, the data will be aligned according to the 

asset's local time zone, so the data logged at 8 AM in Boston will display at the same time position as 8 AM data 

from London. 

 

This functionality requires that the relevant assets have a time zone specified on the General tab of the asset or are 

inheriting a time zone from an ancestor asset. When the time zone is specified the times are aligned in the data 

model and dashboard automatically. No further configuration is required. 

80680 Miscellaneous small enhancements to the data model and example dashboards to provide a better user experience. 

Facility AnalytiX & FDDWorX 

FDDWorX Server 

Ref ID Description 

80786 

75874 

The FDDWorX server and Fault Viewer now support Add Comment and Acknowledge/Resolve/Deactivate Incidents 

actions on a grouped view, such as Fault Statistics. Previously these actions were only supported on the Fault 

Incidents view. 

Fault Viewer 

Ref ID Description 

54791 

The Fault Viewer can now display the estimated lost opportunity cost of incidents. Use the IncidentLostOpp field to 

see this metric. 

 

The lost opportunity is calculated as the normalized fault cost per second for an incident multiplied by the total 

active duration for the incident over the displayed time period. 

80786 

The FDDWorX server and Fault Viewer now support Add Comment and Acknowledge/Resolve/Deactivate Incidents 

actions on a grouped view, such as Fault Statistics. Previously these actions were only supported on the Fault 

Incidents view. 

ReportWorX64 & ReportWorX64 Express 

Major Enhancements 

ReportWorX64 Excel Add-In 

Chart Enhancements for ReportWorX64 Add-In 

(Reference ID: 78146) 

Version 10.97 adds an additional way to work with charts in ReportWorX64 and 

ReportWorX64 Express. Now, charts can be created from a particular data source with 

the aid of a helpful wizard. 
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Charts created from a data source automatically map to the correct cells in the data 

source. The user no longer has to remember what cells to select in the blank data 

source. Charts created from a data source are not visible until data is downloaded, 

allowing the user to place them over the source data, if desired, without obscuring the 

configuration of the data source. 

This feature can also be used to create a series of charts with the number or charts 

depending on the data. This allows reports to dynamically add or remove charts as 

needed when the data changes. 

These charts will automatically update when the new Timer Download feature is used. 

To add a chart from a data source: 

1) Place your cursor in a cell mapped to a data source. 

2) Open the Data source chart configuration dialog by selecting one of the 

following: 

a. ReportWorX64 ribbon > Edit > Chart Settings  

OR 

b. Context menu > Edit > Chart Settings 

3) In the Chart settings section, select data source columns for the X column and Y 

column. 

4) In the Choose chart type section, select Specify chart type, then choose a chart 

type, such as 2D Line. 

5) In Chart position section, select the chart's location with one of the following 

methods: 

a. Select the desired Worksheet. Fill in the X position and Y position with 

the location of the chart's upper left corner in pixels. 

OR 

b. Select the Select position button, then select a cell where you would like 

to align the chart's upper left corner. This can be on another sheet, if 

desired. 

6) Set the width and height of the chart. (A suggestion is to increase the width to 

500 and height to 300 to start with.) 

7) Make other changes, if desired, then select OK. Note, no chart will be 

immediately visible. This is normal. 

8) On the ReportWorX64 ribbon, select Download data. When the data has 

finished downloading your chart will appear. 

9) Select the Clear Data button. The chart will disappear. 

10) Changes can be made to the chart settings by selecting a cell in the data source, 

then returning to the Data source chart configuration dialog using the same 

steps as above. 
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11) If desired, save this workbook and upload it to the ReportWorX64 Server as a 

report template. When the report is generated, the charts will be created, just as 

they are when using the Download data option inside Excel. 

Note, make your data source is configured and mapped correctly before adding a chart 

using the Data source chart configuration. Users cannot update a data sources 

columns, headers, or source tags while a chart exists. To remove a chart and allow 

updating of the data source, select the data source, go to either the ReportWorX64 

ribbon or the context menu, then select Remove > Chart Settings. 

To leverage Excel's extensive chart formatting options, users can create a chart to use as 

a template. In the Choose chart type section, select Use existing chart as template and 

then select the chart to use as a template. All existing formatting will be copied from the 

template chart. The template chart cannot be deleted, but it can be hidden if desired by 

placing it on a particular sheet and hiding that sheet. 

By default, any existing series data in the template chart will be copied into the new 

charts. To prevent this, enable the Clear Series option. 

Optionally, multiple data series can be added to a chart. These series must exist in the 

same data source, with all of their X and Y data in the same columns, and a third column 

must exist with the desired name of each series. An example of this is a data source 

mapped to multiple historical data tags using the Extended data source type.  

Here is an example of adding multiple historical pens was multiple series in a chart: 

1) Place your cursor in a cell. 

2) Go to the ReportWorX64 ribbon or the context menu and select Add > Data 

source. 

3) Select multiple historical tags, then select OK. 

4) Place your cursor in a mapped cell, then edit the data source by going to the 

ReportWorX64 ribbon or the context menu and selecting Edit > Data source. 

5) Set Column Style to Extended. 

6) Select Save and close. 

7) Place your cursor in a mapped cell, then bring up the chart settings by going to 

the ReportWorX64 ribbon or the context menu and selecting Edit > Chart 

Settings. 

8) For X column, choose Timestamp. 

9) For Y column, choose Value. 

10) Enable Use series column. 

11) For Series column, choose PointName. 

12) For chart type, choose 2D Scatter Line. 
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13) Select the chart position and size. 

14) Select OK. 

15) Download the data. Observe that each pen has its own line in the final chart. 

When using a series column, instead of putting all series into one chart, each series can 

have its own chart. Configure the chart as described above but enable Also generate a 

variable number of charts grouped by the value of the series column and choose a 

direction. When downloading the data, you will see additional charts under the first one, 

one chart per unique series value (if using the above example, one chart per pen). 

Adding charts the traditional way (using Excel's native insert chart feature and 

connecting it to blank data source cells) is still supported. Users can choose which chart 

feature suits their reports best, and even use a combination of chart types in their 

reports. 

For Further Reference 

• Help: Chart Support for ReportWorX64 Add-In  

Automatic Update of Real-Time Data Sources 

(Reference ID: 39649) 

Reports with real-time data sources can now be automatically updated in real time. 

Users can configure a data source with real-time data and use the Timer Download 

button to configure the update rate and begin automatically updating the data.  

To stop the updates, select the Stop Download button. 

Note, the Timer Download button can only be used in a ReportWorX64 Excel sheet 

mapped to real-time data sources, and only the real-time data sources on a sheet will 

be updated. 

For Further Reference 

• Help: Automatic Update of Real-Time Data Sources  

Additional Enhancements 

Ref ID Description 

74427 

78147 

The results of a data source can now optionally be resolved as tags, displaying their real-time values in the final 

report. To configure this feature, edit the data source and go to the Resolve Header tab. For each column in the data 

source you would like to resolve, check the Resolve box. 

77304 
Data types that are not supported by Excel are now converted to string. Previously unsupported data types could 

cause unexpected behavior, possibly even a crash. 

80396 

It is now possible to set values for global aliases in the tag name when using the @@Execute tag for a report. For 

example: 

 

rwx:Order Details Report/@@Execute<@param1=ANTON><#alias1=value;#alias2=value> 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/ReportWorX_Express/Excel_Add-In.htm%23Chart_Support_for_ReportWorX64_Add-in
https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/ReportWorX_Express/Automatic_Update_of_Real-Time_Data_Sources.htm
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Ref ID Description 

 

Users can browse for the @@Execute (override Global Aliases) tag in the browser to get a tag that already has the 

appropriate syntax. 

80471 
Added an "Auto Fit Rows" option to report settings. Unchecking this option allows reports to preserve the row height 

from the template. Previous versions always fit the row height after generating the report. 

80583 

79908 

ReportWorX64 and ReportWorX64 Express can now add parameters to a worksheet's header and footer using an 

expression wrapped in <ico></ico> tags. 

 

The expression can be written manually, but to easily generate an expression for the header or footer, select 

Parameters from the ReportWorX64 ribbon, select an existing parameter or create a new one, then select the 

Embedded Expression Editor button. Select one or more attributes (such as Name or Value) to add, then select 

"Generate". Copy the expression (or use the "Copy to clipboard" button), close the Embedded Expression Generator, 

then paste the expression into the worksheet's header or footer.  

 

The expression in the header or footer will be evaluated when "Download Data" is performed or when the 

ReportWorX64 Server runs a report using this file as a template. 

 

Example expressions: 

<ico><<param0>>.Value<\ico> 

<ico><<param1>>.Name,<<param1>>.Value<\ico> 

 

Note, when performing a "Download Data" action, make sure the cursor is not in one of the header or footer fields. 

ReportWorX64 Excel Add-in 

Ref ID Description 

61498 Fixed list and expression parameters can now use other parameters. 

71824 

Excel's conditional formatting can now work with ReportWorX64 data, with some limitations. There should be a one-

to-one relationship between columns and conditional formatting objects (each conditional formatting can only apply 

to one column and each column can only have one conditional formatting applied) and the data source must use the 

fill method of "Auto with expand". 

71999 Added support for formulas that reference tables and table columns (such as "=[Column 1]*5"). 

74295 

ReportWorX64 Express reports can now be configured to auto-fit only certain columns, rather than the whole 

workbook. To configure this, use the context menu or the ReportWorX64 ribbon to select Edit > Header, then check 

the Auto Fit box for the columns you would like to auto fit or use the "Enable Auto Fit for all headers" button. 

 

Note that these settings are only used when performing a download within the ReportWorX64 Excel add-in. The 

ReportWorX64 server does not respect these settings when the file is used as a template. Use the "Auto Fit Columns" 

option in the ReportWorX64 report setting instead. 

74305 

When a parameter allows multi-selection, multiple values can now be chosen when downloading data in the 

ReportWorX64 Excel add-on. 

 

Note that if another parameter depends on the multi-select parameter, only the first selected value will be used. 

Example: Param1 allows multi-selection. Param2 is an automatically calculated parameter that adds 1 to Param1. If 

the user chooses 5 and 10 for Param1, Param2 will equal 6 (the first value of Param1 plus 1).  

79963 

Users can now choose between two schemas for historical data sources using the "Column Style" dropdown. This 

dropdown can be reached using the Edit Data Source option from the ReportWorX64 ribbon or context menu. The 

user can choose between simple and extended modes.  

 

In simple mode, there is a timestamp column and one column for each historical tag. The historical values for the 

same timestamp will appear on the same row.  

 

In extended mode, all historical fields are available (including pen name, low and high ranges, description, and 

engineering units) and there is one column for all values. Each row contains a specific historical sample and its 

properties. If there are multiple tags subscribed, the table is filled with all the samples of all tags, ordered by source. 

 

Some helpful text is displayed below the "Column Style" to help users understand the difference between these two 

modes. 
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Ref ID Description 

"Column Style" replaces the "Always keep extended headers" checkbox in previous versions. 

80465 
The Header Configuration window (context menu or ReportWorX64 Ribbon > Edit > Headers) now allows users to 

reorder the columns. Select a header and use the up and down arrows on the right. 

ReportWorX64 Viewer 

Ref ID Description 

63741 
When downloading reports from the ReportWorX64 Viewer, the default file name now includes random characters. 

This helps ensure that existing files are not accidentally overwritten. 

71160 
The ReportWorX64 Viewer can now cancel reports in Viewer view mode. Previously canceling was only possible in 

Executor view mode. 

80467 When executing reports, users can now override the global alias values. 
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Data Connectivity 

BACnet Connector 

BACnet Workbench Provider 

Ref ID Description 

44070 
The results of Network Discovery can now be exported to a CSV file. Select the "Export Results" hyperlink in the 

Network Results header. 

80936 The MAC address is no longer allowed to be blank when configuring a device with static binding. 

SNMP Connector 

SNMP Server 

Ref ID Description 

76592 
When exploring a network or device using SNMP v3, the SNMP point manager now displays an error if the username 

or password was entered incorrectly. (Previous versions only logged these errors to TraceWorX.) 

SNMP Workbench Provider 

Ref ID Description 

74931 The Explore Network dialog now includes context menu options to select or deselect all devices. 

74964 Hex Bytes is now an available syntax for SNMP tags. 

Web Services Connector 

Major Enhancements 

Support for Query Interface and Table Control 

(Reference ID: 75109) 

The Web Services Connector now supports the query interface. This means that controls 

that support the query interface (such as the table control, when using a type of "query") 

can connect to Web Services and display web method data. 

To see Web Services data in the table control: 

1) Configure the table control. 

2) For Query, select type. 

3) For Data Source, browse under Data Connectivity > Web Services and select 

your desired web method.  

4) The Table field should automatically be populated with the name of the chosen 

web method. 

5) Go to the Fields page. 

6) Select the refresh  button. 
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7) Go to the Columns page. 

8) Select the refresh  button. 

9) Make further updates to Fields or Columns as desired. 

10) Select OK. 

11) Go into runtime to see your data. 

Future ICONICS products that use the query interface will be able to access web services 

information in a similar fashion. 

Query interface support was added for additional data sources. See Additional Data 

Sources for Query Interface for more information. 

For Further Reference 

• Help: Support for Query Interface and Table Control 

Additional Enhancements 

Ref ID Description 

81000 
Individual services now expose an @@Refresh writable point that can be used to refresh all web methods belonging 

to the service. 

 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/WebServices/Support_for_Query_Interface_and_Table_Control.htm
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GENESIS64 

Alarms and Notifications 

Major Enhancements 

Hyper Alarm Server 

New Hyper Alarm Server 

(Reference ID: 76400) 

ICONICS introduces a new alarm server in version 10.97, the Hyper Alarm Server. 

The Hyper Alarm Server offers ISA 18.2-compliant and redundant alarming using all new 

technology, allowing for better performance, more control, native integration with 

FrameWorX communication, and configuration via AssetWorX. The Hyper Alarm Server 

is configured in Workbench under Alarms and Notifications > Hyper Alarm Server. 

New in the Hyper Alarm 

Server, users define alarm 

types, which act as a template 

or class for alarm tags. The 

type defines the core logic 

behind an alarm, its states or 

conditions, when it is 

evaluated, and more. The 

sample Hyper Alarm Server 

configuration includes several 

of the most common alarm 

types.  

In the past, the AlarmWorX64 

Server had a set of hard-coded 

alarm types – such as digital or 

limit – that worked in very 

specific ways. Users with specific needs could not always get the alarm behavior they 

needed. Hyper Alarm Server alarm types give users the freedom to customize the way 

alarms work without having to implement counterintuitive workarounds or request 

product enhancements.  
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Alarm tags are instances of alarm 

types that provide the actual alarm 

capability. An alarm tag defines 

specific values for the fields of its 

alarm type. These specific values may 

include the data source, message text, 

severity, limit values, etc. 

Alarm tags are organized by area and 

configured under Hyper Alarm Server 

> Areas. Areas act as folders for the 

alarms. They are organized in a tree 

structure, with tags as the leaves of the 

tree. This tree structure with alarms nested directly inside provides a more intuitive way 

to organize and navigate alarms than the flat list of alarms with a separate structure of 

areas provided by the AlarmWorX64 Server. 

Alarm counters provide a way to count or summarize the activity in an area, exposing 

the information as a real-time value. They are defined under Hyper Alarm Server > 

Product Configuration > Counters. Users may recognize these counters from the 

AssetWorX configuration, as they work in the same way. Counters can be browsed under 

the root of any area under the Hyper Alarm Server. The sample Hyper Alarm Server 

configuration comes with six preconfigured counters that fill the most common 

counting needs, such as the number of active or unacknowledged alarms in an area. 

Similar to Hyper Historian, the Hyper Alarm Server integrates with AssetWorX. As an 

alternative to adding alarm tags under Hyper Alarm Server > Areas, they can be added 

using the Alarms tab of equipment properties under Assets > Equipment. Alarm tags 

added via AssetWorX use the configured real-time aspect of the equipment property as 

the data source. The rest of the values can be filled in the same as they would be when 

adding a tag under the Hyper Alarm Server. 

When alarms are configured via AssetWorX, they use the asset tree structure as areas. 

Alarm clients can subscribe to either Assets or to Hyper Alarm Server > !Assets. In 

either case, users can also choose to subscribe to a particular asset to get only child 

alarms of that asset. 

As when using integrated Hyper Historian tags, the alarms can be incorporated into 

equipment classes, allowing users to easily instantiate many alarms at once using the 

Bulk Asset Configurator's ClassInstantiation or ClassInstantiationRowsBased sheets. The 

ClassAlarmDefinitions sheet is not used to instantiate alarm tags in the Hyper Alarm 

Server. 
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Because the Hyper Alarm Server was designed from the ground up with FrameWorX in 

mind, its data path is more direct than AlarmWorX64 Server. There is no more 

conversion between old and new technologies. This makes the Hyper Alarm Server more 

robust and better performing than the AlarmWorX64 Server. 

There are additional benefits to the Hyper Alarm Server over AlarmWorX64 Server. For 

instance, the Hyper Alarm Server allows users to access historical reads for a tag, letting 

users easily configure rate-of-change or similar alarm types – something that has always 

been challenging for the AlarmWorX64 Server. Also, the Hyper Alarm Server allows 

unlimited related values, whereas the AlarmWorX64 Server allows only twenty. 

The AlarmWorX64 Server is still available for the sake of backwards compatibility, but for 

new systems users are encouraged to use the new Hyper Alarm Server for forward 

compatibility, best performance, and the most extensive functionality. 

The Hyper Alarm Server uses the AlarmWorX64 Server license, so it can be used with any 

product that includes AlarmWorX64 Server. Licensing is node-based, so the Hyper Alarm 

Server and AlarmWorX64 Server can both run on the same machine at the same time 

even with only one available AlarmWorX64 Server license. The Hyper Alarm Server 

consumes GENESIS64 tags for alarm inputs. 

The Hyper Alarm Server is also available for IoTWorX edge devices. 

For Further Reference 

• Application Note: Hyper Alarm Server – Quick Start 

• Help: About Hyper Alarm Server 

Additional Enhancements 

AlarmWorX64 Logger 

Ref ID Description 

81588 
The AlarmWorX64 Logger Point Manager now exposes the .TimeZoneAlign tag in the data browser. Subscribing to 

this tag will show source local timestamps. This syntax was usable in earlier versions but was not browsable. 

AlarmWorX64 Server 

Ref ID Description 

54022 
The AlarmWorX64 Server previously allowed alarms to be shelved even if they were both acknowledged and normal. 

This is no longer allowed. 

58842 

A real-time tag can now be used to enable or disable the Out of Service, Suppress by Design, and Shelve features for 

an alarm. The tag for each feature can be supplied on the Advanced Settings section of an alarm tag in Workbench. 

Users who do not wish to use tags can supply a 1 to enable or 0 to disable each feature. 

73296 The re-alarm feature, when triggered, now keeps the actor ID and comment of the original alarm. 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/Hyper_Alarm_Server/About_Hyper_Alarm_Server.htm
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AlarmWorX64 Multimedia 

Ref ID Description 

68757 The phone agent now supports remote configuration databases. 

AlertWorX 

Ref ID Description 

75076 

Users who do not require acknowledgment functionality or logged status updates now have a more secure option for 

supplying credentials.  

 

Users who need acknowledgment or logged status updates still need to supply these credentials: 

* Main account SID 

* Account token 

 

Now, users who do not need acknowledgment or logged status updates can supply these more secure credentials 

instead: 

* Main account SID 

* API key SID 

* API key secret 

 

See the help documentation for more details on how to obtain these credentials and use them in ICONICS software. 

75922 

AlertWorX maintains a blacklist of users who have opted out of SMS messages sent via Twilio, AT&T, or Vonage. If 

alerts are configured to be sent to a user on this blacklist, AlertWorX will not send the message. This behavior has not 

changed, but previously there was no record in the AlertRest runtime log of the request to message the user. Now, a 

clear record is added to the AlertRest runtime indicating that the recipient was on the blacklist and the SMS was not 

sent. 

AlertWorX Workbench Provider 

Ref ID Description 

65617 

Workbench now ensures that there is only one node per type (email and SMS/text) that has "Receive commands on 

this node" enabled. When a user enables "Receive commands on this node" for one node, all other nodes of that 

type have "Receive commands" disabled. 

80547 AlertWorX now supports online changes. 

AssetWorX 

Major Enhancements 

AssetWorX Point Manager 

Support for Query Interface and Table Control 

(Reference ID: 74682) 

AssetWorX now supports the query interface. This means that controls that support the 

query interface (such as the table control, when using a type of "query") can connect to 

AssetWorX and list information about assets. 

To see asset data in the table control: 

1) Configure the table control. 
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2) For Query, select type. 

3) For Data Source, browse under Assets and select .Query. 

4) For Table, select either Equipment or Equipment Properties. 

5) Go to the Fields page. 

6) Select the refresh  button. 

7) Go to the Columns page. 

8) Select the refresh  button. 

9) Make further updates to Fields or Columns as desired. 

10) Select OK. 

11) Go into runtime to see your data. 

Future ICONICS products that use the query interface will be able to access asset 

information in a similar fashion. 

Query interface support was added for additional data sources. See Additional Data 

Sources for Query Interface for more information. 

For Further Reference 

• Help: Support for Query Interface and Table Control 

Additional Enhancements 

AssetWorX Point Manager 

Ref ID Description 

74707 
The Analyzer tab is now available when configuring Hyper Historian Calculated Tags, Simple Events, and Conditions 

from AssetWorX. Previously, the Analyzer tab was only visible when configuring these tags from Hyper Historian. 

AssetWorX Navigator 

Ref ID Description 

61370 
Added an Asset Icons option on the General page in the Navigator section. It is enabled by default. Disabling it will 

hide the asset icons. 

Controls 

Major Enhancements 

Table Control 

Query Top and Distinct Records 

(Reference IDs: 77235, 77236, 78097) 

The Table control can now display only the top N records or distinct records. 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/AssetWorX/Support_for_Query_Interface_and_Table_Control.htm
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To return only distinct records, configure the table control, go to the Fields page, and 

enable Distinct. 

To limit the records returned to the top rows, configure the table control, go to the 

Fields page, enable Limit Record Count, and set the desired limit with Record Count. 

For Further Reference 

• Help: Query Top and Distinct Records 

Sankey Diagram 

New Control: Sankey Diagram 

(Reference ID: 81518) 

There is a new control in 

version 10.97, the Sankey 

diagram. Sankey diagrams help 

illustrate flow between 

different sources and 

destinations. 

Sankey diagrams can be added 

to GraphWorX64 displays 

using the Controls ribbon. 

Sankey is usable in desktop 

(WPF) and HTML5 displays. 

Support for Sankey diagrams 

in the Universal Windows 

Platform (UWP) app is planned 

for future versions. 

The Sankey diagram expects a dataset with three columns, a source, a destination, and a 

weight. In runtime, the diagram will intelligently draw the correctly weighted lines 

between each source and destination. Optionally, gains and losses can be visualized. The 

colors and shapes of the nodes and links can be extensively customized, if desired. The 

control supports all of the features of modern ICONICS controls, such as a customizable 

context menu and commanding support. 

There is also a Sankey diagram widget available in KPIWorX. 

For Further Reference 

• Help: Sankey Diagram 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/GWX/Table.htm#Query_Top_and_Distinct_Records
https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/GWX/Sankey_Diagram.htm
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Additional Enhancements 

Data Diagram 

Ref ID Description 

74233 

The Data Diagram can now have tooltips displaying information such as the sample value. This is configured on the 

Samples page in the new Tooltip section. This is currently supported in desktop (WPF) and Universal Windows 

Platform (UWP). Support for tooltips in HTML5 is planned for a future version. 

EarthWorX Viewer 

Ref ID Description 

42717 
Added a "Localize Map" property to map layers. When set to true the map will be localized according to the client's 

operating system regional settings. This supports Bing and Google maps, but only if map credentials are used. 

79587 Improved the experience of selecting a map type when choosing from a large list of types. 

Recipe Navigator 

Ref ID Description 

56571 Minor user interface enhancements. 

Table Control 

Ref ID Description 

74590 

Columns with a numerical datatype can now have a content type of "Icon". Previously only string columns could use 

the Icon content type. This allows users to an expression to convert a number into a valid icon path. 

 

The @@value context variable is now only available for columns linked to fields. 

 

The @@resolvedvalue context variable is now only available for DataSource content types. 

75161 
Added an option to show row numbers. Use the "Row Header" option in the Table ribbon, or from the table 

configuration go to the Rows page, to the Row Header section, then enable Row Numbers. 

TrendWorX64 Viewer 

Ref ID Description 

80772 

80940 
The Axis Stroke property can now be set in the Create Pen command. 

81023 The Edit Trend Chart command can now update the pen buffer size. 

GraphWorX64  

Ref ID Description 

19493 

Added a new property to objects called "MovesOwnerWindow". When set to True, the user can click and drag this 

item and the ancestor window will follow it. 

 

This property can be used to create custom title bars for popup windows. It is only supported in desktop (WPF) 

displays. 

26938 

Data entry process points with a keypad now have the option of specifying a custom keypad layout XML file. The URL 

of the file can be entered into the CustomKeypadLayout property. This property is only visible in Advanced mode. 

Example keypad XML files can be found under \GENESIS64\Components\Layouts\KeyPad\. Note, the keypads feature 

is only available in desktop (WPF). 

34929 Multi-line data entry keypads now have a scroll bar. 

41504 
The high and low range numbers that appear in the data entry keypad now match the format of the process point's 

current value. 
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Ref ID Description 

44359 

44489 

44729 

46760 

The experience of configuring a display in grid mode has been enhanced, including: 

• The grid context menu is now available from all borders. Previously it was only available from the top or left 

borders. 

• Both borders now change color to indicate when pixel or auto length is chosen for that row or column. Previously 

only the top or left borders changed color in this way. 

• The size of the relevant rows or columns now appears when dragging a dividing line to change the size of a row or 

column. This makes it easier to resize columns without having to guess at the exact measurements. 

• Double-clicking a grid border now opens the configuration dialog for the rows or columns. 

• Star and pixel lengths now round to a reasonable number of decimal places when the grid dividers are dragged. 

45466 

Previously, the same message would be shown whether no symbols were found in a completed search and when a 

user canceled the symbol library search before any symbols were found. Now the symbol library makes it clear 

whether there were no symbols found because there are none or because the search did not find any before it was 

stopped. 

46181 The symbol library now automatically scrolls to the position of newly pasted symbols. 

54550 

The Find and Replace dialogs now include a "Wildcards" checkbox. When disabled wildcards are not used and only 

literal matches are found. This can help users who are searching for text that includes wildcards (for instance, 

<#aliases#>). 

55036 

Users can now force a transform to rotate an object 90 degrees or flip it. To force a transform, hold down the Shift 

key when pressing the ribbon or context menu buttons to rotate or flip. 

 

The benefit of using a transform, compared to a default rotate or flip, is that it will allow the "Update Shared" feature 

to preserve the orientation of the object as desired. Objects that have been rotated or flipped the default way may 

not have their orientation preserved when using the "Update Shared" feature. 

76952 

In previous versions, when importing DWG/DFX files, if the file contained font sizes outside of the allowed range it 

would cause an error and the file would not be imported. Now the importer replaces the font size with either the 

maximum or minimum allowed font size and allows the file to be imported. 

80906 

80509 

80907 

80954 

Enhanced the dark theme coloring for various dialogs and elements. 

3D Viewport 

Ref ID Description 

50399 The size of the selected object is now displayed in the details section of the 3D Viewport in configuration mode. 

74448 
The IFC import dialog includes a new checkbox called, "Import Space Objects". When checked, the IfcSpace objects 

will be imported as geometries. 

75026 
The IFC import dialog now includes a checkbox for "Use Active Database". This is enabled by default. Users can 

disable it to specify a custom database. 

Web Publishing Wizard 

Ref ID Description 

37144 Improved the HTTP error messages shown when there is an error in publishing. 

46120 

When choosing a protocol for publishing there is a new "ftps" option available (implicit FTP over SSL/TLS). This 

option automatically choses FTP port 990. It assumes that displays will be accessed via HTTPS, so the generated HTM 

files will use HTTPS. Publishing to FTPS encrypts passwords and data, and thus is more secure than publishing via 

FTP. 
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GridWorX 

GridWorX Server 

Ref ID Description 

59910 
GridWorX connections now expose an @@Refresh writable point that can be used to refresh all data sources 

belonging to the connection. 

GridWorX Viewer 

Ref ID Description 

72063 

72064 

72062 

Series now include a property called HideZeroValues. When set to True, all samples in the series with a value of zero 

are hidden, including their labels and legend entries. This property is supported in desktop (WPF), HTML5, and 

Universal Windows Platform (UWP). 

ScheduleWorX64 

Schedule Control 

Ref ID Description 

71917 

The desktop (WPF) Schedule Control (including the BACnet schedule view) now only enables the Apply Schedule 

button in the runtime ribbon and toolbar when there are changes that need to be applied. 

 

The HTML5 Schedule Control (including the BACnet schedule view) now only enables the Apply Schedule context 

menu button if there are changes that need to be applied. 
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Hyper Historian 

Major Enhancements 

Data Exporter 

Support for Amazon Simple Storage Service (S3) and Azure Data Lake Generation 2 

(Reference IDs: 64987, 74407) 

The Data Exporter now supports the export of data from Hyper Historian into Amazon 

Simple Storage Service (also known as Amazon S3) and Azure Data Lake Gen2 storage 

types. 

To configure the new storage types, create a new storage in Workbench under 

Historical Data > Hyper Historian > Data Exporters > Storage. Set the Connection 

Type to Amazon S3 or Azure Data Lake Gen2. Configure the rest of the connection 

properties as required for your connection type. 

For Further Reference 

• Help: Support for Amazon Simple Storage Service (S3) and Azure Data Lake 

Generation 2 

Additional Enhancements 

Hyper Historian Collector 

Ref ID Description 

67237 
Hyper Historian standalone collector installations can now configure the advanced settings for OPC UA connections 

in the "OPC UA Servers Configuration" tool. 

Hyper Historian Logger 

Ref ID Description 

77125 

The packaging interval can now be set on collectors (both in-process and out-of-process). The packaging interval is 

the rate at which updates from the collector are sent to the logger and made available for data replay. In previous 

versions, the data packaging interval was hard coded at 5 seconds. 

 

Note that while speeding up this interval will allow OPC UA and OPC HDA clients faster access to historical data, it 

can increase CPU usage and network traffic. 

Hyper Historian Workbench Provider 

Ref ID Description 

55426 Improved some error messages to be more user friendly and clearer about steps needed to resolve the error. 

77442 Added Percent Bad and Start Time options to aggregate groups. 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/HH/Data_Exporter.htm%23Support_for_Amazon_Simple_Storage_Service__S3__and_Azure_Data_Lake_Generation_2
https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/HH/Data_Exporter.htm%23Support_for_Amazon_Simple_Storage_Service__S3__and_Azure_Data_Lake_Generation_2
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IoTWorX & Internet of Things 

IoT General 

Major Features 

Hyper Alarm Server 

(Reference ID: 81507) 

Alarming support has been added to edge devices with the inclusion of the Hyper Alarm 

Server. Users can configure alarms for their edge devices in their IoT template under 

Alarms and Notifications > Hyper Alarm Server. 

The IoTWorX Hyper Alarm Server is configured the same as the desktop version. As of 

version 10.97 the alarms configured for an edge Hyper Alarm Server are only available 

locally to the edge device. They can be viewed in the IoT Visualizer on the device using 

an Alarm Grid or Alarm List widget.  

Support for publishing Hyper Alarm Server alarms is planned for a future version. 

For Further Reference 

• Help: Hyper Alarm Server - IoTWorX 

Additional Enhancements 

Ref ID Description 

71928 
In the data browser under Internet of Things > connection > device > All Available Data, the icons and order of items 

has been updated to be consistent with other areas of ICONICS. 

78149 

The login of the edge device's Diagnostics and Configuration pages now contains a "Forgot password" link. This link 

generates a challenge code that the user can provide to ICONICS technical support. Once the proper answer is 

provided, the passwords for the "admin" and "user" accounts in the IoTWorX Console are reset to the default of 

"iconics". 

 

This allows users to regain entry to a system when the password has been lost without completely resetting all of the 

provisioning information. 

 

Password reset attempts are logged to GenEvents. 

81153 Improved the reliability for determining container IP addresses, which are used for inter-container communication. 

81409 The trace log can now be downloaded from the TraceViewer page in the edge user interface. 

IoT Analyzer 

Ref ID Description 

66801 

Unchecking the IoT Asset option on an asset under FDDWorX tab > Advanced Settings now removes the asset from 

the IoT configuration database. (Previously, assets that were configured as IoT Assets remained in the IoT 

configuration database until being removed directly via SQL queries.) 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Com/Tools/IoTWorX/Hyper_Alarm_Server.htm
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Internet of Things Workbench Provider 

Ref ID Description 

74285 
Subscriber connections that do not have compatibility with ICONICS clients enabled can now select "None" as the 

Default Decoder. 

81960 

Subscriber connections have a new option called "Convert incoming raw messages into events." Previously, all 

subscriber connections converted incoming raw messages into events. This option allows users to turn this 

functionality off. Users planning to use the Information Broker functionality should make sure to keep this option 

enabled. 

 

This option is disabled by default for new subscriber connections, but subscriber connections upgraded from a 

previous version will have it enabled to remain consistent with the functionality in the previous version. 

Workbench IoT Project 

Ref ID Description 

80817 
The context menu for devices now contains an option to restart all modules. This is in addition to the preexisting 

option to restart just the core modules. 

BACnet Workbench Provider in IoT Projects 

Ref ID Description 

78623 

When creating a device instance manually (choosing "Add Device" from the context menu, not using Network 

Discovery), there is a new option for "Scan the object properties when the form is applied." As stated, when this 

option is selected, applying the form to create the device will automatically scan to discover the properties. Prior to 

this, only the objects could be discovered automatically. 
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KPIWorX 

Major Enhancements 

General 

Color Palette Editor 

(Reference ID: 57289) 

Many charts and widgets use a color palette to define the color of the chart elements. 

Starting in version 10.97, users can create their own color palettes for use in these 

widgets. 

Color palettes can be edited from the Theme Manager. Go to Settings > Themes, then 

select Palettes from the theme manager sidebar. Select the + button at the bottom to 

add a new palette. Select a palette color position (a checkmark will appear in the 

selected box), choose a color from the panel on the right, then select the  fill button to 

add the color to the selected position. Repeat for each desired color position. 

Palette color positions can be added or removed using the + and - buttons on the 

palette row. 

To copy a color from an existing palette, select the desired color from the existing 

palette, copy the HEXA value, and paste it into the HEXA field of the desired position. 

Remember to select the  fill button. 

To remove a custom palette, select the palette, then select the - button at the bottom of 

the theme manager. 

Edits to an existing palette will automatically be propagated to any widgets that use the 

palette. 

For Further Reference 

• Help: Color Palette Editor 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/KPIWorX/Color_Palette_Editor.htm
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Widgets 

New Widget: Sankey Diagram 

(Reference ID: 48684) 

There is a new widget in version 10.97, 

the Sankey diagram. Sankey diagrams 

help illustrate flow between different 

sources and destinations. 

The Sankey diagram can be found in 

the Charts section of the Component 

Library. It expects two datasets. One 

must have three columns, a source, a 

destination, and a weight. These are 

mapped to the From, To, and Value 

fields of the widget, respectively. The 

other dataset must be a list of the possible From and To node names. This is mapped to 

the Nodes field of the widget and must match the values in the From and To columns of 

the first dataset. Currently the dataset used for the Nodes field only needs a single 

column, but additional columns may be used in the future to specify properties of the 

nodes, used in customizing the Sankey diagram.  

This separate Nodes dataset must come from the same AnalytiX-BI data model. Using a 

separate independent dataset (such as two GridWorX datasets) is not supported. Users 

have the option of using the same column as the From or To fields for the Node field, 

even if not all possible nodes appear in the column. (For example, if your data source 

has three columns, FromNode, ToNode, and Weight, you could use FromNode for both 

the Node and From field.) 

There is also a Sankey diagram control available for GraphWorX64 and MobileHMI 

displays. 

For Further Reference 

• Help: Sankey Diagram - KPIWorX 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/KPIWorX/Sankey_Diagram.htm
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Widget Updates to "Web First" Technology 

(Reference ID: 68606) 

KPIWorX widgets are being redesigned with a new technology referred to as "web first". 

The tree control in 10.96.2 was the first widget to use this new technology. Version 10.97 

also uses web first technology for the new Sankey diagram and redesigned the gauge, 

goal tracker, data diagram, and symbol widgets to leverage web first. 

The largest benefit to web first technology is that the rendering is done on the client 

side. This improves the scalability and performance of the system, especially when 

running many KPIWorX clients from the same server. It can also make user interactions, 

such as highlighting, dragging, and animations, seem faster and more natural. 

ICONICS is also working on updating the categorical, donut, funnel, pie, and treemap 

widgets to web first technology. These widgets are still in the beta stage, but they have 

been included in KPIWorX in version 10.97 for users who would like to give them a try.  

Users who are ready to try these experimental beta widgets can edit the 

Ico.AnyGlass.KPIWorX.config file in \ICONICS\GENESIS64\WebSites\AnyGlass\Bin. 

Set WebFirstExperimentalWidgets to true and save the file. Refresh your browser if 

KPIWorX was already open. You should now have a WF Charts category in your 

component library. These charts should behave exactly like the standard charts, only 

more responsive. 

Remember that the widgets in this category are only in beta. We will appreciate if users 

can report differences between these web first widgets and their standard counterparts 

so we can improve them for the next version. Report any issues or differences to 

technical support, and make sure to mention that you are using the ones in the WF 

Charts category. 

If you are not sure whether a chart in your dashboard is a standard or web first chart, 

make sure you are in edit mode, select the widget, and go to the component library. 

The component type will be selected, and you can observe whether it is in the Charts or 

WF Charts category. 

Additional Enhancements 

Ref ID Description 

61597 
Charts configured to highlight sections that match the filter now have a separate tooltip for the filtered segment and 

the total segment. 

64676 
The trend widget can now have multiple axes, defined in the Vertical Axes section. Once additional axes are defined, 

choose an axis for a pen by selecting your series, selecting the pen in the series, then changing the Axis field. 
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Ref ID Description 

65414 

The Share > Image > Download option for widgets and dashboards now downloads a PNG file. In previous versions, 

choosing Share > Image > Download would download an HTML file. Note that the download button may take a 

moment to enable as the image is generated. 

66577 Minor user interface enhancements and improved error messages. 

72884 GraphWorX64-specific tooltips are no longer shown in KPIWorX when a symbol is imported from GraphWorX64. 

78341 

In version 10.96.2, the day that starts the week was determined by the AnalytiX-BI server that is providing the data. 

Now, the day that starts the week is determined by the client's regional settings. This determines the sorting order of 

the DayOfWeek subcolumn. 

79433 
Widgets and dashboards can now be shared as PDFs. Select the More button for a dashboard or widget, then select 

Share > PDF. Note that the Email and Download buttons may take a moment to enable as the PDF is generated. 

79615 A legend was added to the map widget when the path symbol is in use. 

80036 Widget-level filters are now available on the gauge, goal tracker, and symbol widgets. 

80980 

The string representing the active filter on a dashboard can now be copied. This string can be pasted into the Load 

KPI Dashboard command's Parameters property. This makes it easy to create commands that open dashboards with 

filters already applied. 

 

Create or open a saved dashboard, apply your desired filter, then in the dashboard header select the More > Share > 

Filter String > Clipboard. Paste the string into the Parameters property of a Load KPI Dashboard command. 
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MobileHMI & HTML5 WebHMI 

HTML5, iOS, Android Platform 

Major Enhancements 

Utilize Client Location for Displays and Commands 

(Reference IDs: 64630, 64631) 

HTML5 displays can now access client location data to set global aliases and 

automatically execute commands. This works in the MobileHMI app for iOS and Android 

and in HTML5-compliant browsers. 

To enable location access, follow these steps on the desired client device: 

1) Go to the App Hub page. 

2) Open the context menu. 

3) Select Preferences. 

4) In the Location section, select Enabled. 

5) If desired, enable Commands and set the desired Distance. The distance tunes 

the sensitivity (in meters) of checking for nearby commands. 

When the location is enabled, the client's location will be written to the 

<#AR\ar_longitude#> and <#AR\ar_latitude#> global aliases. These aliases can then 

be used to show location-specific information in displays. 

If location commands are enabled, the user can launch the App Hub to check if there 

are any geofence commands available. Geofence commands are defined in Workbench 

under MobileHMI > Configuration > Augmented Reality. If the user is inside a 

geofence a message will appear, asking if the user would like to execute the defined 

command. 

For Further Reference 

• Help: Utilize Client Location for Displays and Commands 

Feature Parity Improvements 

HTML5 browsers and the MobileHMI apps for iOS and Android can now use the 

following features and functionality that were previously only available in the desktop 

GraphWorX64 app (WPF) or the Universal Windows Platform (WPF) MobileHMI app. 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/MobileHMI/Utilize_Client_Location_for_Displays_and_Commands.htm
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General 
Ref ID Description 

63653 

The HTML5 security logon dialog can now show a list of existing usernames. This can be toggled with the "Provide 

list of existing users in the login dialog" option in Security's Global Settings and is consistent with the login dialog in 

desktop (WPF). 

AlarmWorX64 Viewer 
Ref ID Description 

81261 
The HTML5 AlarmWorX64 Viewer now supports the "Show Dialog" sub-command of the "Set Time Range" global 

command. 

81701 The HTML5 AlarmWorX64 Viewer now supports the Time Zone setting on event points. 

Asset Navigator 
Ref ID Description 

60632 Enhanced the styling of the HTML5 Asset Navigator to be more consistent with the desktop (WPF) styling. 

GraphWorX64  
Ref ID Description 

75408 
All parameters for process point data entry confirmation are now supported. Previously only tag name and new value 

were supported. 

79265 The localsim:property:Owner* syntax is now supported in HTML5. 

GridWorX Viewer  
Ref ID Description 

77497 
GridWorX Viewer tooltips are now consistent with desktop (WPF) formatting, including the new formatting styles 

introduced for WPF in version 10.96. 

TrendWorX64 Viewer 
Ref ID Description 

24400 The HTML5 TrendWorX64 Viewer now supports the Export Statistics global command. 

46046 The HTML5 TrendWorX64 Viewer now supports the "Show invalid pens" option (Chart > Pens tab). 

67887 The HTML5 TrendWorX64 Viewer now supports the filename output parameter for the ExportData command. 

68950 

Users can now drag in the summary view outside of the selected area to scroll. This allows users to easily move to 

areas outside of the currently displayed summary view. Previously dragging was not allowed and clicking outside of 

the selected area would jump the selected range to that area. 

79774 

When the Show ToolBar option is disabled, the same items that would be shown in the desktop (WPF) TrendWorX64 

Viewer's toolbar are now hidden from the HTML5 TrendWorX64 Viewer's context menu. (Show ToolBar is located on 

the Appearance tab of the top-level item when configuring the control.) 

 

Note, to completely disable the context menu, also disable Context Menu on the chart object on the Chart tab. 

 

* Note that localsim:property tags are not universally supported in HTML5 due to the 

difference in structure between desktop (WPF) and HTML5 displays. Where possible, 

commanding should be used instead of modifying localsim:property tags. 

Additional Enhancements 

General 

Ref ID Description 

72878 

Added a new page to troubleshoot MobileHMI/HTML5 communication issues. The troubleshooting page must be 

enabled by setting <UseSignalr enabled="true" /> in the ico.anyglass.parsing.config. The page is located at 

http://hostname/AnyGlass/connection-test.html. Contact technical support for assistance using this page to 

troubleshoot WebSockets communication issues. 

80417 

Users may see high load times of HTML5 displays if a large number of clients (around 20 or more - the exact number 

may vary) attempt to connect at the same time, such as when restarting FrameWorX or IIS. To help improve this 

behavior, the HTML5 server can be configured to limit the number of clients that can be processed at one time.  
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Ref ID Description 

  

This feature is turned off by default (no limit to parallel client processing). To enable it, edit the 

ico.anyglass.serviceEngine.config file (located by default in Program 

Files\ICONICS\GENESIS64\WebSites\AnyGlass\Bin) and change the PerformanceBarrierLimit value to a positive 

integer. This is the limit of clients that will be processed at one time. 

81145 
To create a more secure system, the directory browsing feature has been disabled by default for the Project 

subdirectory of the AnyGlass virtual folder. Users who wish to use this feature can re-enable it in IIS after installation. 

App Hub 

Ref ID Description 

81176 Enhanced error tracing when encountering a problem with a URL in the App Hub. 

GraphWorX64 

Ref ID Description 

65234 Enhanced the loading speed of displays in embedded GraphWorX64 Viewers. 

80674 

The local Load Display command has been enhanced in HTML5 displays to allow popups in new browser windows.  

 

To configure, use a pick action with these settings: 

* Command: Load Display (local command) 

* TargetType: Popup Window (any) 

* OverrideWindowProperties: True 

* WindowProperties: Set the Left, Top, Width and Height values of the desired popup display.  

 

Note that this functionality is designed for use in desktop browsers. Certain clients, such as mobile phones, will not 

be able to set the window position due to limitations of the platform. 

 

Also note, in this version users need to set the edit mode to "Desktop App" to configure these settings. Support for 

these properties will be added to "Web Browser" mode in future versions. 

GridWorX Viewer 

Ref ID Description 

72063 

Series now include a property called HideZeroValues. When set to True, all samples in the series with a value of zero 

are hidden, including their labels and legend entries. This property is supported in desktop (WPF), HTML5, and 

Universal Windows Platform (UWP). 

Schedule Control 

Ref ID Description 

71917 

The desktop (WPF) Schedule Control (including the BACnet schedule view) now only enables the Apply Schedule 

button in the runtime ribbon and toolbar when there are changes that need to be applied. 

 

The HTML5 Schedule Control (including the BACnet schedule view) now only enables the Apply Schedule context 

menu button if there are changes that need to be applied. 

TrendWorX64 Viewer 

Ref ID Description 

81023 The Edit Trend Chart command can now update the pen buffer size. 
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Universal Windows Platform (UWP) 

Major Enhancements 

Execute Augmented Reality Commands with Geofences 

(Reference ID: 77526) 

Users of the MobileHMI Universal Windows Platform (UWP) app can execute commands 

based on whether they are within geofences. 

Create or edit a geofence in Workbench under MobileHMI > Configuration > 

Augmented Reality. (A geofence is a location with a type of Geofence). Go to the 

Actions Settings tab and configure your desired action. 

In the MobileHMI UWP app, enter Augmented Reality mode. If you are within a 

geofence with a configured command a message will appear, asking if you want to 

execute the command. 

For Further Reference 

• Help: Execute Augmented Reality Commands with Geofences

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/MobileHMI/Execute_Augmented_Reality_Commands_with_Geofences.htm
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Workbench 

Major Enhancements 

Project Reporting 

New Implementation Using ReportWorX64 Technology 

(Reference ID: 77481) 

Project Reporting has been reimplemented in version 10.97 to no longer require SQL 

Server Reporting Services (SSRS).  

The configuration of project reports is the same as in previous versions. Select your 

project in Project Explorer, bring up the context menu, then select one of the report 

options, such as Configured Tags Report or Runtime Use Report. The report 

configuration forms should look the same. 

Project Reporting templates are now created using the ReportWorX64 Express Excel 

add-in, not the SSRS configurator. Note, Project Reporting templates must only use tags 

that start with cfg. A ReportWorX64 license is not required to use Project Reporting or 

create custom templates. 

To support the new implementation, many datasets that were previously only available 

in an SSRS report file are now accessible via the data browser. These datasets can be 

found under Diagnostics > Configuration in the new Availability, Entities, and Usage 

folders. Many of these datasets can be used outside of Project Reporting, such as in the 

Table control or GridWorX Viewer. 

For Further Reference 

• Help: Using ReportWorX64 Technology in Project Reporting 

Additional Enhancements 

General 

Ref ID Description 

40371 The "Generate relative paths" setting in the import and export dialog is now remembered between uses. 

48911 
The "Compare packages" dialog now includes a "Show only differences" option. This allows users to quickly see the 

differences between two projects without having to look through the entire project contents. 

71332 
When creating a new entity in an empty configuration the user will be prompted to make the new entity the active or 

default if one is required. (Example: when creating a new configuration entity under Reports > Configurations.)  

73121 Various small user interface improvements across Workbench and many providers. 

79728 
When using the "Export" or "Clipboard" options for the Installation Details page, only visible data is exported or 

copied. This allows users to filter the data prior to the action and only export or copy the data they are interested in. 

79850 
Pack and Go's unpack process can now add an application to the target project if it was not already present. This 

includes creating the databases, if necessary, and starting services. 

https://docs.iconics.com/V10.97/GENESIS64/Help/ICONICS_Product_Help.htm#Apps/WBDT/ProjectWorX/Project_Reporting_Section.htm%23Using_ReportWorX64_Technology_in_Project_Reporting
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Ref ID Description 

80949 

80964 

Previously, if a PowerShell cmdlet parameter needed to be obfuscated or encrypted, such as the password parameter 

of Set-AlertEmail, the user needed to obfuscate or encrypt the parameter manually before passing it into the cmdlet. 

Now, parameters that require obfuscation or encryption do so automatically. They no longer need to be explicitly 

obfuscated or encrypted before calling the cmdlet. 

Project Files 

Ref ID Description 

72592 

Added a new option to the context menu of archives: "Backup from original path". This option will take a new backup 

of all of the files in the archive from their original location. This allows users to easily take a "snapshot" of all of their 

files when they have reached a particular milestone without having to go through the longer process of importing 

individual files. 

80010 
The Advanced Import now contains a checkbox for "Retain relative paths under destination". When enabled, the 

advanced import will attempt to retain the relative paths of the files with respect to the destination. 
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